What’s Vulnerable › Vulnerabilities
CVE-2020-3975
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-21 · updated 2026-06-17
- Weakness: CWE-79
Description
VMware App Volumes 2.x prior to 2.18.6 and VMware App Volumes 4 prior to 2006 contain a Stored Cross-Site Scripting (XSS) vulnerability. A malicious actor with access to create and edit applications or create storage groups, may be able to inject malicious script which will be executed by a victim's browser when viewing.
Affected products
- VMware App Volumes: from 2.0 before 2.18.6; from 4 before 2006 — fixed in 2.18.6, 2006
- VMware App Volumes: from VMware App Volumes 2.x prior through 2.18.6 and VMware App Volumes 4 prior to 2006
How to fix
Upgrade to a fixed version: VMware App Volumes 2.18.6, 2006. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2020-0019.html
- https://www.vmware.com/security/advisories/VMSA-2020-0019.html
Get alerted when CVE-2020-3975 or the next vulnerability affects your stack