What’s Vulnerable › Vulnerabilities
CVE-2020-3995
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-20 · updated 2026-06-17
- Weakness: CWE-401
Description
In VMware ESXi (6.7 before ESXi670-201908101-SG, 6.5 before ESXi650-202007101-SG), Workstation (15.x before 15.1.0), Fusion (11.x before 11.1.0), the VMCI host drivers used by VMware hypervisors contain a memory leak vulnerability. A malicious actor with access to a virtual machine may be able to trigger a memory leak issue resulting in memory resource exhaustion on the hypervisor if the attack is sustained for extended periods of time.
Affected products
- VMware Cloud Foundation: from 3.0 before 3.9 — fixed in 3.9
- VMware ESXi: 6.7-670-201806001, 6.7-670-201807001, 6.7-670-201808001, 6.7-670-201810001, 6.7-670-201810101, 6.7-670-201810102 (+163); 6.7, 6.5
- VMware Fusion: from 11.0.0 before 11.1.0 — fixed in 11.1.0
- VMware Workstation: from 15.0.0 before 15.1.0 — fixed in 15.1.0
- VMware ESXi, Workstation, Fusion: VMware ESXi (6.7 before ESXi670-201908101-SG, 6.5 before ESXi650-202007101-SG), Workstation (15.x before 15.1.0), Fusion (11.x before 11.1.0)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.9; VMware Fusion 11.1.0; VMware Workstation 15.1.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2020-0023.html
- https://www.vmware.com/security/advisories/VMSA-2020-0023.html
Get alerted when CVE-2020-3995 or the next vulnerability affects your stack