What’s Vulnerable › Vulnerabilities
CVE-2020-4005
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-20 · updated 2026-06-17
Description
VMware ESXi (7.0 before ESXi70U1b-17168206, 6.7 before ESXi670-202011101-SG, 6.5 before ESXi650-202011301-SG) contains a privilege-escalation vulnerability that exists in the way certain system calls are being managed. A malicious actor with privileges within the VMX process only, may escalate their privileges on the affected system. Successful exploitation of this issue is only possible when chained with another vulnerability (e.g. CVE-2020-4004)
Affected products
- VMware Cloud Foundation: from 3.0 before 3.10.1.2; from 4.0 before 4.1.0.1 — fixed in 3.10.1.2, 4.1.0.1
- VMware ESXi: 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101, 6.5-650-201707102 (+170); 6.5, 6.7, 7.0
- VMware ESXi: 7.0 before ESXi70U1b-17168206, 6.7 before ESXi670-202011101-SG, 6.5 before ESXi650-202011301-SG
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.10.1.2, 4.1.0.1. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2020-0026.html
- https://www.vmware.com/security/advisories/VMSA-2020-0026.html
Get alerted when CVE-2020-4005 or the next vulnerability affects your stack