What’s Vulnerable › Vulnerabilities

CVE-2020-4038: Reflected XSS in GraphQL Playground

Description

GraphQL Playground (graphql-playground-html NPM package) before version 1.6.22 have a severe XSS Reflection attack vulnerability. All unsanitized user input passed into renderPlaygroundPage() method could trigger this vulnerability. This has been patched in graphql-playground-html version 1.6.22. Note that some of the associated dependent middleware packages are also affected including but not limited to graphql-playground-middleware-express before version 1.7.16, graphql-playground-middleware-koa before version 1.6.15, graphql-playground-middleware-lambda before version 1.7.17, and graphql-playground-middleware-hapi before 1.6.13.

Affected products

How to fix

Upgrade to a fixed version: prisma Graphql-Playground-Html 1.6.22; prisma Graphql-Playground-Middleware-Express 1.7.16; prisma Graphql-Playground-Middleware-Hapi 1.6.13; prisma Graphql-Playground-Middleware-Koa 1.6.15; prisma Graphql-Playground-Middleware-Lambda 1.7.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-4038 or the next vulnerability affects your stack