What’s Vulnerable › Vulnerabilities
CVE-2020-4043: Phar unserialization vulnerability in phpMussel
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-10 · updated 2026-06-17
- Weakness: CWE-502
Description
phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.
Affected products
- phpMussel: from 1.0.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: phpMussel 1.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4
- https://github.com/phpMussel/phpMussel/issues/167
- https://github.com/phpMussel/phpMussel/pull/173
- https://github.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fh
- https://github.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities
- https://github.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4
- https://github.com/phpMussel/phpMussel/issues/167
- https://github.com/phpMussel/phpMussel/pull/173
- https://github.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fh
- https://github.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities
Get alerted when CVE-2020-4043 or the next vulnerability affects your stack