What’s Vulnerable › Vulnerabilities
CVE-2020-4047: Authenticated XSS via media attachment page in WordPress
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-12 · updated 2026-06-17
- Weakness: CWE-80
Description
In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 32, 33
- WordPress: from 3.7 before 3.7.34; from 3.8 before 3.8.34; from 3.9 before 3.9.32; from 4.0 before 4.0.31; from 4.1 before 4.1.31; from 4.2 before 4.2.28 — fixed in 3.7.34, 3.8.34, 3.9.32, 4.0.31, 4.1.31, 4.2.28
How to fix
Upgrade to a fixed version: WordPress 3.7.34, 3.8.34, 3.9.32, 4.0.31. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/commit/0977c0d6b241479ecedfe19e96be69f727c3f81f
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-8q2w-5m27-wm27
- https://lists.debian.org/debian-lts-announce/2020/07/msg00000.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00011.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/773N2ZV7QEMBGKH6FBKI6Q5S3YJMW357/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ODNHXVJS25YVWYQHOCICXTLIN5UYJFDN/
- https://wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
- https://www.debian.org/security/2020/dsa-4709
- https://github.com/WordPress/wordpress-develop/commit/0977c0d6b241479ecedfe19e96be69f727c3f81f
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-8q2w-5m27-wm27
- https://lists.debian.org/debian-lts-announce/2020/07/msg00000.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00011.html
Get alerted when CVE-2020-4047 or the next vulnerability affects your stack