What’s Vulnerable › Vulnerabilities

CVE-2020-4051: XSS in Dijit Editor's LinkDialog plugin

Description

In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.

Affected products

How to fix

Upgrade to a fixed version: Openjsf Dijit 1.11.11, 1.12.9, 1.13.8, 1.14.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-4051 or the next vulnerability affects your stack