What’s Vulnerable › Vulnerabilities
CVE-2020-4054: Cross-site Scripting in Sanitize
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-16 · updated 2026-06-17
- Weakness: CWE-79
Description
In Sanitize (RubyGem sanitize) greater than or equal to 3.0.0 and less than 5.2.1, there is a cross-site scripting vulnerability. When HTML is sanitized using Sanitize's "relaxed" config, or a custom config that allows certain elements, some content in a math or svg element may not be sanitized correctly even if math and svg are not in the allowlist. You are likely to be vulnerable to this issue if you use Sanitize's relaxed config or a custom config that allows one or more of the following HTML elements: iframe, math, noembed, noframes, noscript, plaintext, script, style, svg, xmp. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML through Sanitize, potentially resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. This has been fixed in 5.2.1.
Affected products
- rgrove sanitize: from 3.0.0 before 5.2.1 — fixed in 5.2.1
- Rubygems Sanitize: from 3.0.0 before 5.2.1; 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.1.0 (+19) — fixed in 5.2.1
How to fix
Upgrade to a fixed version: rgrove sanitize 5.2.1; Rubygems Sanitize 5.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/rgrove/sanitize/commit/a11498de9e283cd457b35ee252983662f7452aa9
- https://github.com/rgrove/sanitize/releases/tag/v5.2.1
- https://github.com/rgrove/sanitize/security/advisories/GHSA-p4x4-rw2p-8j8m
- https://usn.ubuntu.com/4543-1/
- https://www.debian.org/security/2020/dsa-4730
- https://github.com/rgrove/sanitize/commit/a11498de9e283cd457b35ee252983662f7452aa9
- https://github.com/rgrove/sanitize/releases/tag/v5.2.1
- https://github.com/rgrove/sanitize/security/advisories/GHSA-p4x4-rw2p-8j8m
- https://usn.ubuntu.com/4543-1/
- https://www.debian.org/security/2020/dsa-4730
Get alerted when CVE-2020-4054 or the next vulnerability affects your stack