What’s Vulnerable › Vulnerabilities
CVE-2020-4066: Command Injection in Limdu trainBatch function
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-22 · updated 2026-06-17
- Weakness: CWE-78
Description
In Limdu before 0.95, the trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. This has been patched in 0.95.
Affected products
- erelsgl Limdu: before 0.9.5 — fixed in 0.9.5
How to fix
Upgrade to a fixed version: erelsgl Limdu 0.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/erelsgl/limdu/security/advisories/GHSA-77qv-gh6f-pgh4
- https://github.com/erelsgl/limdu/security/advisories/GHSA-77qv-gh6f-pgh4
Get alerted when CVE-2020-4066 or the next vulnerability affects your stack