What’s Vulnerable › Vulnerabilities
CVE-2020-4074: Improper Authentication
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-02 · updated 2026-06-17
- Weakness: CWE-287
Description
In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, the authentication system is malformed and an attacker is able to forge requests and execute admin commands. The problem is fixed in 1.7.6.6.
Affected products
- PrestaShop: from 1.5.0.0 before 1.7.6.6 — fixed in 1.7.6.6
How to fix
Upgrade to a fixed version: PrestaShop 1.7.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/30b6a7bdaca9cb940d3ce462906dbb062499fc30
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-ccvh-jh5x-mpg4
- https://github.com/PrestaShop/PrestaShop/commit/30b6a7bdaca9cb940d3ce462906dbb062499fc30
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-ccvh-jh5x-mpg4
Get alerted when CVE-2020-4074 or the next vulnerability affects your stack