What’s Vulnerable › Vulnerabilities
CVE-2020-4267
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-24 · updated 2026-06-17
- Weakness: CWE-401
Description
IBM MQ and MQ Appliance 8.0, 9.1 LTS, and 9.1 CD could allow an authenticated user cause a denial of service due to a memory leak. IBM X-Force ID: 175840.
Affected products
- IBM MQ: from 8.0.0.0 before 8.0.0.14; from 9.1.0.0 before 9.1.0.4 — fixed in 8.0.0.14, 9.1.0.4
- IBM MQ Appliance: from 9.1.0 before 9.1.5 — fixed in 9.1.5
How to fix
Upgrade to a fixed version: IBM MQ 8.0.0.14, 9.1.0.4; IBM MQ Appliance 9.1.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/175840
- https://www.ibm.com/support/pages/node/6195384
- https://exchange.xforce.ibmcloud.com/vulnerabilities/175840
- https://www.ibm.com/support/pages/node/6195384
Get alerted when CVE-2020-4267 or the next vulnerability affects your stack