What’s Vulnerable › Vulnerabilities
CVE-2020-4310
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-16 · updated 2026-06-17
Description
IBM MQ and MQ Appliance 7.1, 7.5, 8.0, 9.0 LTS, 9.1 LTS, and 9.1 C are vulnerable to a denial of service attack due to an error within the Data Conversion logic. IBM X-Force ID: 177081.
Affected products
- IBM MQ: from 8.0.0.0 before 8.0.0.15; from 9.0.0.0 before 9.0.0.10; from 9.1.0 before 9.1.5; from 9.1.0.0 before 9.1.0.5 — fixed in 8.0.0.15, 9.0.0.10, 9.1.0.5, 9.1.5
- IBM Corporation WebSphere MQ: 7.1, 7.5
How to fix
Upgrade to a fixed version: IBM MQ 8.0.0.15, 9.0.0.10, 9.1.0.5, 9.1.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/177081
- https://www.ibm.com/support/pages/node/6223914
- https://exchange.xforce.ibmcloud.com/vulnerabilities/177081
- https://www.ibm.com/support/pages/node/6223914
Get alerted when CVE-2020-4310 or the next vulnerability affects your stack