What’s Vulnerable › Vulnerabilities
CVE-2020-4375
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-28 · updated 2026-06-17
- Weakness: CWE-401
Description
IBM MQ, IBM MQ Appliance, IBM MQ for HPE NonStop 8.0, 9.1 CD, and 9.1 LTS could allow an attacker to cause a denial of service due to a memory leak caused by an error creating a dynamic queue. IBM X-Force ID: 179080.
Affected products
- IBM MQ Appliance: from 8.0 before 8.0.0.15; from 9.1.0.0 before 9.1.0.6; from 9.1.0.0 before 9.2.0.0 — fixed in 8.0.0.15, 9.1.0.6, 9.2.0.0
How to fix
Upgrade to a fixed version: IBM MQ Appliance 8.0.0.15, 9.1.0.6, 9.2.0.0. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/179080
- https://www.ibm.com/support/pages/node/6252785
- https://exchange.xforce.ibmcloud.com/vulnerabilities/179080
- https://www.ibm.com/support/pages/node/6252785
Get alerted when CVE-2020-4375 or the next vulnerability affects your stack