What’s Vulnerable › Vulnerabilities
CVE-2020-4530
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Business Automation Workflow C.D.0 and IBM Business Process Manager 8.0, 8.5, and 8.6 are vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-ForceID: 182714.
Affected products
- IBM Business Automation Workflow: before 20.0.0.2 — fixed in 20.0.0.2
- IBM Business Process Manager: from 8.0.0.0 before 8.0.1.0; from 8.5.0.0 before 8.5.7.0; 8.6.0.0 — fixed in 8.0.1.0, 8.5.7.0
How to fix
Upgrade to a fixed version: IBM Business Automation Workflow 20.0.0.2; IBM Business Process Manager 8.0.1.0, 8.5.7.0. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/182714
- https://www.ibm.com/support/pages/node/6332417
- https://exchange.xforce.ibmcloud.com/vulnerabilities/182714
- https://www.ibm.com/support/pages/node/6332417
Get alerted when CVE-2020-4530 or the next vulnerability affects your stack