What’s Vulnerable › Vulnerabilities
CVE-2020-4575
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-27 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM WebSphere Application Server ND 8.5 and 9.0, and IBM WebSphere Virtual Enterprise 7.0 and 8.0 are vulnerable to cross-site scripting when High Availability Deployment Manager is configured.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.18; from 9.0.0.0 before 9.0.5.5 — fixed in 8.5.5.18, 9.0.5.5
- IBM WebSphere Virtual Enterprise: 7.0, 8.0
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.18, 9.0.5.5. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/184363
- https://www.ibm.com/support/pages/node/6323293
- https://exchange.xforce.ibmcloud.com/vulnerabilities/184363
- https://www.ibm.com/support/pages/node/6323293
Get alerted when CVE-2020-4575 or the next vulnerability affects your stack