What’s Vulnerable › Vulnerabilities
CVE-2020-4938
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-352
Description
IBM MQ Appliance 9.1 and 9.2 is vulnerable to cross-site request forgery which could allow an attacker to execute malicious and unauthorized actions transmitted from a user that the website trusts. IBM X-Force ID: 191815.
Affected products
- IBM MQ Appliance: from 9.1 before 9.2.2; from 9.1.0.0 before 9.1.0.8; from 9.2.0.0 before 9.2.0.2 — fixed in 9.1.0.8, 9.2.0.2, 9.2.2
How to fix
Upgrade to a fixed version: IBM MQ Appliance 9.1.0.8, 9.2.0.2, 9.2.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/191815
- https://www.ibm.com/support/pages/node/6466717
- https://exchange.xforce.ibmcloud.com/vulnerabilities/191815
- https://www.ibm.com/support/pages/node/6466717
Get alerted when CVE-2020-4938 or the next vulnerability affects your stack