What’s Vulnerable › Vulnerabilities
CVE-2020-5204: Buffer overflow vulnerability in uftpd
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-06 · updated 2026-06-17
- Weakness: CWE-121
Description
In uftpd before 2.11, there is a buffer overflow vulnerability in handle_PORT in ftpcmd.c that is caused by a buffer that is 16 bytes large being filled via sprintf() with user input based on the format specifier string %d.%d.%d.%d. The 16 byte size is correct for valid IPv4 addresses (len('255.255.255.255') == 16), but the format specifier %d allows more than 3 digits. This has been fixed in version 2.11
Affected products
- troglobit uftpd: before 2.11 — fixed in 2.11
How to fix
Upgrade to a fixed version: troglobit uftpd 2.11. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00034.html
- https://github.com/troglobit/uftpd/commit/0fb2c031ce0ace07cc19cd2cb2143c4b5a63c9dd
- https://github.com/troglobit/uftpd/security/advisories/GHSA-wrpr-xw7q-9wvq
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00034.html
- https://github.com/troglobit/uftpd/commit/0fb2c031ce0ace07cc19cd2cb2143c4b5a63c9dd
- https://github.com/troglobit/uftpd/security/advisories/GHSA-wrpr-xw7q-9wvq
Get alerted when CVE-2020-5204 or the next vulnerability affects your stack