What’s Vulnerable › Vulnerabilities
CVE-2020-5208: remote code execution vulnerability in ipmitool
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-05 · updated 2026-06-17
- Weakness: CWE-120
Description
It's been found that multiple functions in ipmitool before 1.8.19 neglect proper checking of the data received from a remote LAN party, which may lead to buffer overflows and potentially to remote code execution on the ipmitool side. This is especially dangerous if ipmitool is run as a privileged user. This problem is fixed in version 1.8.19.
Affected products
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 30, 31
- Ipmitool Project Ipmitool: 1.8.18
- openSUSE Leap: 15.1
References
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00031.html
- https://github.com/ipmitool/ipmitool/commit/e824c23316ae50beb7f7488f2055ac65e8b341f2
- https://github.com/ipmitool/ipmitool/security/advisories/GHSA-g659-9qxw-p7cp
- https://lists.debian.org/debian-lts-announce/2020/02/msg00006.html
- https://lists.debian.org/debian-lts-announce/2021/06/msg00029.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K2BPW66KDP4H36AGZXLED57A3O2Y6EQW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RYYEKUAUTCWICM77HOEGZDVVEUJLP4BP/
- https://security.gentoo.org/glsa/202101-03
- http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00031.html
- https://github.com/ipmitool/ipmitool/commit/e824c23316ae50beb7f7488f2055ac65e8b341f2
- https://github.com/ipmitool/ipmitool/security/advisories/GHSA-g659-9qxw-p7cp
- https://lists.debian.org/debian-lts-announce/2020/02/msg00006.html
Get alerted when CVE-2020-5208 or the next vulnerability affects your stack