What’s Vulnerable › Vulnerabilities
CVE-2020-5214: NetHack error recovery after syntax error in configuration file is subject to a buffer overflow
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-120
Description
In NetHack before 3.6.5, detecting an unknown configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.
Affected products
- NetHack: before 3.6.5 — fixed in 3.6.5
How to fix
Upgrade to a fixed version: NetHack 3.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/NetHack/NetHack/security/advisories/GHSA-p8fw-rq89-xqx6
- https://github.com/NetHack/NetHack/security/advisories/GHSA-p8fw-rq89-xqx6
Get alerted when CVE-2020-5214 or the next vulnerability affects your stack