What’s Vulnerable › Vulnerabilities
CVE-2020-5216: Limited header injection when using dynamic overrides with user input in RubyGems secure_headers
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-23 · updated 2026-06-17
- Weakness: CWE-113
Description
In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.
Affected products
- Twitter secure_headers: before 3.9.0; from 5.0.0 before 5.2.0; from 6.0.0 before 6.3.0 — fixed in 3.9.0, 5.2.0, 6.3.0
How to fix
Upgrade to a fixed version: Twitter secure_headers 3.9.0, 5.2.0, 6.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0
- https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg
- https://github.com/twitter/secure_headers/commit/301695706f6a70517c2a90c6ef9b32178440a2d0
- https://github.com/twitter/secure_headers/security/advisories/GHSA-w978-rmpf-qmwg
Get alerted when CVE-2020-5216 or the next vulnerability affects your stack