What’s Vulnerable › Vulnerabilities
CVE-2020-5217: Directive injection when using dynamic overrides with user input in RubyGems secure_headers
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-23 · updated 2026-06-17
- Weakness: CWE-95
Description
In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.8.0, 5.1.0, and 6.2.0. If user-supplied input was passed into append/override_content_security_policy_directives, a semicolon could be injected leading to directive injection. This could be used to e.g. override a script-src directive. Duplicate directives are ignored and the first one wins. The directives in secure_headers are sorted alphabetically so they pretty much all come before script-src. A previously undefined directive would receive a value even if SecureHeaders::OPT_OUT was supplied. The fixed versions will silently convert the semicolons to spaces and emit a deprecation warning when this happens. This will result in innocuous browser console messages if being exploited/accidentally used. In future releases, we will raise application errors resulting in 500s. Depending on what major version you are using, the fixed versions are 6.2.0, 5.1.0, 3.8.0.
Affected products
- Twitter secure_headers: before 3.8.0; from 5.0.0 before 5.1.0; from 6.0.0 before 6.2.0 — fixed in 3.8.0, 5.1.0, 6.2.0
How to fix
Upgrade to a fixed version: Twitter secure_headers 3.8.0, 5.1.0, 6.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/twitter/secure_headers/commit/936a160e3e9659737a9f9eafce13eea36b5c9fa3
- https://github.com/twitter/secure_headers/issues/418
- https://github.com/twitter/secure_headers/pull/421
- https://github.com/twitter/secure_headers/security/advisories/GHSA-xq52-rv6w-397c
- https://github.com/twitter/secure_headers/commit/936a160e3e9659737a9f9eafce13eea36b5c9fa3
- https://github.com/twitter/secure_headers/issues/418
- https://github.com/twitter/secure_headers/pull/421
- https://github.com/twitter/secure_headers/security/advisories/GHSA-xq52-rv6w-397c
Get alerted when CVE-2020-5217 or the next vulnerability affects your stack