What’s Vulnerable › Vulnerabilities
CVE-2020-5227: Feedgen Vulnerable to XML Denial of Service Attacks
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-776
Description
Feedgen (python feedgen) before 0.9.0 is susceptible to XML Denial of Service attacks. The *feedgen* library allows supplying XML as content for some of the available fields. This XML will be parsed and integrated into the existing XML tree. During this process, feedgen is vulnerable to XML Denial of Service Attacks (e.g. XML Bomb). This becomes a concern in particular if feedgen is used to include content from untrused sources and if XML (including XHTML) is directly included instead of providing plain tex content only. This problem has been fixed in feedgen 0.9.0 which disallows XML entity expansion and external resources.
Affected products
- lkiesow python-feedgen: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: lkiesow python-feedgen 0.9.0. Check the vendor advisory for mitigations.
References
- https://docs.microsoft.com/en-us/archive/msdn-magazine/2009/november/xml-denial-of-service-attacks-and-defenses
- https://github.com/lkiesow/python-feedgen/commit/f57a01b20fa4aaaeccfa417f28e66b4084b9d0cf
- https://github.com/lkiesow/python-feedgen/security/advisories/GHSA-g8q7-xv52-hf9f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T6I5ENUYGFNMIH6ZQ62FZ6VU2WD3SIOI/
- https://docs.microsoft.com/en-us/archive/msdn-magazine/2009/november/xml-denial-of-service-attacks-and-defenses
- https://github.com/lkiesow/python-feedgen/commit/f57a01b20fa4aaaeccfa417f28e66b4084b9d0cf
- https://github.com/lkiesow/python-feedgen/security/advisories/GHSA-g8q7-xv52-hf9f
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T6I5ENUYGFNMIH6ZQ62FZ6VU2WD3SIOI/
Get alerted when CVE-2020-5227 or the next vulnerability affects your stack