What’s Vulnerable › Vulnerabilities
CVE-2020-5230: Opencast uses unsafe identifiers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-30 · updated 2026-06-17
- Weakness: CWE-99
Description
Opencast before 8.1 and 7.6 allows almost arbitrary identifiers for media packages and elements to be used. This can be problematic for operation and security since such identifiers are sometimes used for file system operations which may lead to an attacker being able to escape working directories and write files to other locations. In addition, Opencast's Id.toString(…) vs Id.compact(…) behavior, the latter trying to mitigate some of the file system problems, can cause errors due to identifier mismatch since an identifier may unintentionally change. This issue is fixed in Opencast 7.6 and 8.1.
Affected products
- opencast: before 7.6; 8.0 — fixed in 7.6
How to fix
Upgrade to a fixed version: opencast 7.6. Check the vendor advisory for mitigations.
References
- https://github.com/opencast/opencast/commit/bbb473f34ab95497d6c432c81285efb0c739f317
- https://github.com/opencast/opencast/security/advisories/GHSA-w29m-fjp4-qhmq
- https://github.com/opencast/opencast/commit/bbb473f34ab95497d6c432c81285efb0c739f317
- https://github.com/opencast/opencast/security/advisories/GHSA-w29m-fjp4-qhmq
Get alerted when CVE-2020-5230 or the next vulnerability affects your stack