What’s Vulnerable › Vulnerabilities
CVE-2020-5242: openHAB exec add-ons allow remote arbitrary command execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-20 · updated 2026-06-17
- Weakness: CWE-284
Description
openHAB before 2.5.2 allow a remote attacker to use REST calls to install the EXEC binding or EXEC transformation service and execute arbitrary commands on the system with the privileges of the user running openHAB. Starting with version 2.5.2 all commands need to be whitelisted in a local file which cannot be changed via REST calls.
Affected products
- openhab-webui: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: openhab-webui 2.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/openhab/openhab-addons/commit/4c4cb664f2e2c3866aadf117d22fb54aa8dd0031
- https://github.com/openhab/openhab-addons/security/advisories/GHSA-w698-693g-23hv
- https://github.com/openhab/openhab-addons/commit/4c4cb664f2e2c3866aadf117d22fb54aa8dd0031
- https://github.com/openhab/openhab-addons/security/advisories/GHSA-w698-693g-23hv
Get alerted when CVE-2020-5242 or the next vulnerability affects your stack