What’s Vulnerable › Vulnerabilities
CVE-2020-5244: Private data exposure via REST API in BuddyPress
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-24 · updated 2026-06-17
- Weakness: CWE-284
Description
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
Affected products
- BuddyPress: from 5.0.0 before 5.1.2 — fixed in 5.1.2
How to fix
Upgrade to a fixed version: BuddyPress 5.1.2. Check the vendor advisory for mitigations.
References
- https://buddypress.org/2020/01/buddypress-5-1-2/
- https://github.com/buddypress/BuddyPress/commit/39294680369a0c992290577a9d740f4a2f2c2ca3
- https://github.com/buddypress/BuddyPress/security/advisories/GHSA-3j78-7m59-r7gv
- https://buddypress.org/2020/01/buddypress-5-1-2/
- https://github.com/buddypress/BuddyPress/commit/39294680369a0c992290577a9d740f4a2f2c2ca3
- https://github.com/buddypress/BuddyPress/security/advisories/GHSA-3j78-7m59-r7gv
Get alerted when CVE-2020-5244 or the next vulnerability affects your stack