What’s Vulnerable › Vulnerabilities
CVE-2020-5248: Public GLPIKEY can be used to decrypt any data in GLPI
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-12 · updated 2026-06-17
- Weakness: CWE-798
Description
GLPI before before version 9.4.6 has a vulnerability involving a default encryption key. GLPIKEY is public and is used on every instance. This means anyone can decrypt sensitive data stored using this key. It is possible to change the key before installing GLPI. But on existing instances, data must be reencrypted with the new key. Problem is we can not know which columns or rows in the database are using that; espcially from plugins. Changing the key without updating data would lend in bad password sent from glpi; but storing them again from the UI will work.
Affected products
- glpi-project glpi: before 9.4.6 — fixed in 9.4.6
How to fix
Upgrade to a fixed version: glpi-project glpi 9.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/efd14468c92c4da43333aa9735e65fd20cbc7c6c
- https://github.com/glpi-project/glpi/security/advisories/GHSA-j222-j9mf-h6j9
- https://github.com/glpi-project/glpi/commit/efd14468c92c4da43333aa9735e65fd20cbc7c6c
- https://github.com/glpi-project/glpi/security/advisories/GHSA-j222-j9mf-h6j9
Get alerted when CVE-2020-5248 or the next vulnerability affects your stack