What’s Vulnerable › Vulnerabilities
CVE-2020-5268: Subject Confirmation Method not validated in Saml2 Authentication Services for ASP.NET
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-21 · updated 2026-06-17
- Weakness: CWE-303
Description
In Saml2 Authentication Services for ASP.NET versions before 1.0.2, and between 2.0.0 and 2.6.0, there is a vulnerability in how tokens are validated in some cases. Saml2 tokens are usually used as bearer tokens - a caller that presents a token is assumed to be the subject of the token. There is also support in the Saml2 protocol for issuing tokens that is tied to a subject through other means, e.g. holder-of-key where possession of a private key must be proved. The Sustainsys.Saml2 library incorrectly treats all incoming tokens as bearer tokens, even though they have another subject confirmation method specified. This could be used by an attacker that could get access to Saml2 tokens with another subject confirmation method than bearer. The attacker could then use such a token to create a log in session. This vulnerability is patched in versions 1.0.2 and 2.7.0.
Affected products
- Sustainsys Saml2: before 1.0.2; from 2.0.0 before 2.7.0 — fixed in 1.0.2, 2.7.0
How to fix
Upgrade to a fixed version: Sustainsys Saml2 1.0.2, 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/Sustainsys/Saml2/commit/e58e0a1aff2b1ead6aca080b7cdced55ee6d5241
- https://github.com/Sustainsys/Saml2/issues/712
- https://github.com/Sustainsys/Saml2/security/advisories/GHSA-9475-xg6m-j7pw
- https://www.nuget.org/packages/Sustainsys.Saml2/
- https://github.com/Sustainsys/Saml2/commit/e58e0a1aff2b1ead6aca080b7cdced55ee6d5241
- https://github.com/Sustainsys/Saml2/issues/712
- https://github.com/Sustainsys/Saml2/security/advisories/GHSA-9475-xg6m-j7pw
- https://www.nuget.org/packages/Sustainsys.Saml2/
Get alerted when CVE-2020-5268 or the next vulnerability affects your stack