What’s Vulnerable › Vulnerabilities
CVE-2020-5279: Improper Access Control for certain legacy controller in PrestaShop
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-20 · updated 2026-06-17
- Weakness: CWE-284
Description
In PrestaShop between versions 1.5.0.0 and 1.7.6.5, there are improper access control since the the version 1.5.0.0 for legacy controllers. - admin-dev/index.php/configure/shop/customer-preferences/ - admin-dev/index.php/improve/international/translations/ - admin-dev/index.php/improve/international/geolocation/ - admin-dev/index.php/improve/international/localization - admin-dev/index.php/configure/advanced/performance - admin-dev/index.php/sell/orders/delivery-slips/ - admin-dev/index.php?controller=AdminStatuses The problem is fixed in 1.7.6.5
Affected products
- PrestaShop: from 1.5.0.0 (excl.) before 1.7.6.5 — fixed in 1.7.6.5
How to fix
Upgrade to a fixed version: PrestaShop 1.7.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/4444fb85761667a2206874a3112ccc77f657d76a
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-74vp-ww64-w2gm
- https://github.com/PrestaShop/PrestaShop/commit/4444fb85761667a2206874a3112ccc77f657d76a
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-74vp-ww64-w2gm
Get alerted when CVE-2020-5279 or the next vulnerability affects your stack