What’s Vulnerable › Vulnerabilities
CVE-2020-5287: Improper access control on customers search in PrestaShop
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-20 · updated 2026-06-17
- Weakness: CWE-284
Description
In PrestaShop between versions 1.5.5.0 and 1.7.6.5, there is improper access control on customers search. The problem is fixed in 1.7.6.5.
Affected products
- PrestaShop: from 1.5.5.0 (excl.) before 1.7.6.5 — fixed in 1.7.6.5
How to fix
Upgrade to a fixed version: PrestaShop 1.7.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/27e49d89808f1d76eb909a595f344a6739bc0b52
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-r6rp-6gv6-r9hq
- https://github.com/PrestaShop/PrestaShop/commit/27e49d89808f1d76eb909a595f344a6739bc0b52
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-r6rp-6gv6-r9hq
Get alerted when CVE-2020-5287 or the next vulnerability affects your stack