What’s Vulnerable › Vulnerabilities
CVE-2020-5317
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC ECS versions prior to 3.4.0.1 contain an XSS vulnerability. A remote authenticated malicious user could exploit this vulnerability to store malicious HTML or JavaScript code in a trusted application data store. When victim users access the data store through their browsers, the malicious code gets executed by the web browser in the context of the vulnerable web application.
Affected products
- Dell Elastic Cloud Storage: before 3.4.0.1 — fixed in 3.4.0.1
How to fix
Upgrade to a fixed version: Dell Elastic Cloud Storage 3.4.0.1. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/security/en-us/details/540788/DSA-2020-016-Dell-EMC-ECS-Cross-Site-Scripting-XSS-Vulnerability
- https://www.dell.com/support/security/en-us/details/540788/DSA-2020-016-Dell-EMC-ECS-Cross-Site-Scripting-XSS-Vulnerability
Get alerted when CVE-2020-5317 or the next vulnerability affects your stack