What’s Vulnerable › Vulnerabilities
CVE-2020-5410: Directory Traversal with spring-cloud-config-server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 95.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-02 · updated 2026-06-17
- Weakness: CWE-23
Description
Spring Cloud Config, versions 2.2.x prior to 2.2.3, versions 2.1.x prior to 2.1.9, and older unsupported versions allow applications to serve arbitrary configuration files through the spring-cloud-config-server module. A malicious user, or attacker, can send a request using a specially crafted URL that can lead to a directory traversal attack.
Affected products
- Spring Cloud Config: from 2.1.0 before 2.1.9; from 2.2.0 before 2.2.3 — fixed in 2.1.9, 2.2.3
- Spring Cloud Config: from 2.1 before 2.1.9; from 2.2 before 2.2.3 — fixed in 2.1.9, 2.2.3
How to fix
Upgrade to a fixed version: Spring Cloud Config 2.1.9, 2.2.3; Spring Cloud Config 2.1.9, 2.2.3. Check the vendor advisory for mitigations.
References
- https://tanzu.vmware.com/security/cve-2020-5410
- https://tanzu.vmware.com/security/cve-2020-5410
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2020-5410
Get alerted when CVE-2020-5410 or the next vulnerability affects your stack