What’s Vulnerable › Vulnerabilities
CVE-2020-5415: Concourse's GitLab auth allows impersonation
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-12 · updated 2026-06-17
- Weakness: CWE-290
Description
Concourse, versions prior to 6.3.1 and 6.4.1, in installations which use the GitLab auth connector, is vulnerable to identity spoofing by way of configuring a GitLab account with the same full name as another user who is granted access to a Concourse team. GitLab groups do not have this vulnerability, so GitLab users may be moved into groups which are then configured in the Concourse team.
Affected products
- Pivotal Concourse: before 6.3.1; from 6.4.0 before 6.4.1 — fixed in 6.3.1, 6.4.1
How to fix
Upgrade to a fixed version: Pivotal Concourse 6.3.1, 6.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/concourse/concourse/security/advisories/GHSA-627p-rr78-99rj
- https://tanzu.vmware.com/security/cve-2020-5415
- https://github.com/concourse/concourse/security/advisories/GHSA-627p-rr78-99rj
- https://tanzu.vmware.com/security/cve-2020-5415
Get alerted when CVE-2020-5415 or the next vulnerability affects your stack