What’s Vulnerable › Vulnerabilities
CVE-2020-5417: Cloud Controller may allow developers to claim sensitive routes
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-21 · updated 2026-06-17
- Weakness: CWE-732
Description
Cloud Foundry CAPI (Cloud Controller), versions prior to 1.97.0, when used in a deployment where an app domain is also the system domain (which is true in the default CF Deployment manifest), were vulnerable to developers maliciously or accidentally claiming certain sensitive routes, potentially resulting in the developer's app handling some requests that were expected to go to certain system components.
Affected products
- Cloud Foundry CAPI: before 1.97.0 — fixed in 1.97.0
- Cloud Foundry cf-deployment: before 13.12.0 — fixed in 13.12.0
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.97.0; Cloud Foundry cf-deployment 13.12.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-5417 or the next vulnerability affects your stack