What’s Vulnerable › Vulnerabilities
CVE-2020-5419: RabbitMQ arbitrary code execution using local binary planting
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-08-31 · updated 2026-06-17
- Weakness: CWE-427
Description
RabbitMQ versions 3.8.x prior to 3.8.7 are prone to a Windows-specific binary planting security vulnerability that allows for arbitrary code execution. An attacker with write privileges to the RabbitMQ installation directory and local access on Windows could carry out a local binary hijacking (planting) attack and execute arbitrary code.
Affected products
- rabbitmq-server: from 3.8.0 before 3.8.7 — fixed in 3.8.7
- Pivotal RabbitMQ: before 3.7.28 — fixed in 3.7.28
How to fix
Upgrade to a fixed version: rabbitmq-server 3.8.7; Pivotal RabbitMQ 3.7.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-5419 or the next vulnerability affects your stack