What’s Vulnerable › Vulnerabilities
CVE-2020-5420: Gorouter is vulnerable to DoS attack via invalid HTTP responses
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-03 · updated 2026-06-17
- Weakness: CWE-754
Description
Cloud Foundry Routing (Gorouter) versions prior to 0.206.0 allow a malicious developer with "cf push" access to cause denial-of-service to the CF cluster by pushing an app that returns specially crafted HTTP responses that crash the Gorouters.
Affected products
- Cloud Foundry cf-deployment: before 13.15.0 — fixed in 13.15.0
- Cloudfoundry Gorouter: before 0.206.0 — fixed in 0.206.0
How to fix
Upgrade to a fixed version: Cloud Foundry cf-deployment 13.15.0; Cloudfoundry Gorouter 0.206.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-5420 or the next vulnerability affects your stack