What’s Vulnerable › Vulnerabilities

CVE-2020-5421: RFD Protection Bypass via jsessionid

Description

In Spring Framework versions 5.2.0 - 5.2.8, 5.1.0 - 5.1.17, 5.0.0 - 5.0.18, 4.3.0 - 4.3.28, and older unsupported versions, the protections against RFD attacks from CVE-2015-5211 may be bypassed depending on the browser used through the use of a jsessionid path parameter.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 4.3.29, 5.0.19, 5.1.18, 5.2.9; Spring Framework 4.3.29, 5.0.19, 5.1.18, 5.2.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-5421 or the next vulnerability affects your stack