What’s Vulnerable › Vulnerabilities
CVE-2020-5423: Cloud Controller is vulnerable to denial of service via YAML parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-02 · updated 2026-06-17
- Weakness: CWE-400
Description
CAPI (Cloud Controller) versions prior to 1.101.0 are vulnerable to a denial-of-service attack in which an unauthenticated malicious attacker can send specially-crafted YAML files to certain endpoints, causing the YAML parser to consume excessive CPU and RAM.
Affected products
- Cloud Foundry CAPI: before 1.101.0 — fixed in 1.101.0
- Cloud Foundry cf-deployment: before 15.0.0 — fixed in 15.0.0
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.101.0; Cloud Foundry cf-deployment 15.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-5423 or the next vulnerability affects your stack