What’s Vulnerable › Vulnerabilities
CVE-2020-5724
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-30 · updated 2026-06-17
- Weakness: CWE-89
Description
The Grandstream UCM6200 series before 1.0.20.22 is vulnerable to an SQL injection via the HTTP server's websockify endpoint. A remote unauthenticated attacker can invoke the challenge action with a crafted username and discover user passwords.
Affected products
- Grandstream Ucm6202 Firmware: before 1.0.20.22 — fixed in 1.0.20.22
- Grandstream Ucm6204 Firmware: before 1.0.20.22 — fixed in 1.0.20.22
- Grandstream Ucm6208 Firmware: before 1.0.20.22 — fixed in 1.0.20.22
How to fix
Upgrade to a fixed version: Grandstream Ucm6202 Firmware 1.0.20.22; Grandstream Ucm6204 Firmware 1.0.20.22; Grandstream Ucm6208 Firmware 1.0.20.22. Check the vendor advisory for mitigations.
References
- https://www.tenable.com/security/research/tra-2020-17
- https://www.tenable.com/security/research/tra-2020-17
Get alerted when CVE-2020-5724 or the next vulnerability affects your stack