What’s Vulnerable › Vulnerabilities
CVE-2020-5777
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 23.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-01 · updated 2026-06-17
- Weakness: CWE-287
Description
MAGMI versions prior to 0.7.24 are vulnerable to a remote authentication bypass due to allowing default credentials in the event there is a database connection failure. A remote attacker can trigger this connection failure if the Mysql setting max_connections (default 151) is lower than Apache (or another web server) setting MaxRequestWorkers (formerly MaxClients) (default 256). This can be done by sending at least 151 simultaneous requests to the Magento website to trigger a "Too many connections" error, then use default magmi:magmi basic authentication to remotely bypass authentication.
Affected products
- MAGMI: before 0.7.24 — fixed in 0.7.24
How to fix
Upgrade to a fixed version: MAGMI 0.7.24. Check the vendor advisory for mitigations.
References
- https://www.tenable.com/security/research/tra-2020-51
- https://www.tenable.com/security/research/tra-2020-51
Get alerted when CVE-2020-5777 or the next vulnerability affects your stack