What’s Vulnerable › Vulnerabilities
CVE-2020-5865
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-319
Description
In versions prior to 3.3.0, the NGINX Controller is configured to communicate with its Postgres database server over unencrypted channels, making the communicated data vulnerable to interception via man-in-the-middle (MiTM) attacks.
Affected products
- NGINX Controller: from 2.0.0 through 2.9.0; from 3.0.0 before 3.3.0; 1.0.1 — fixed in 3.3.0
- NetApp Cloud Backup: all versions
How to fix
Upgrade to a fixed version: NGINX Controller 3.3.0. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20200430-0005/
- https://support.f5.com/csp/article/K21009022
- https://security.netapp.com/advisory/ntap-20200430-0005/
- https://support.f5.com/csp/article/K21009022
Get alerted when CVE-2020-5865 or the next vulnerability affects your stack