What’s Vulnerable › Vulnerabilities
CVE-2020-5866
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-200
Description
In versions of NGINX Controller prior to 3.3.0, the helper.sh script, which is used optionally in NGINX Controller to change settings, uses sensitive items as command-line arguments.
Affected products
- NGINX Controller: from 2.0.0 through 2.9.0; from 3.0.0 before 3.3.0; 1.0.1 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: NGINX Controller 3.3.0. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20200430-0005/
- https://support.f5.com/csp/article/K11922628
- https://security.netapp.com/advisory/ntap-20200430-0005/
- https://support.f5.com/csp/article/K11922628
Get alerted when CVE-2020-5866 or the next vulnerability affects your stack