What’s Vulnerable › Vulnerabilities
CVE-2020-5867
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-319
Description
In versions prior to 3.3.0, the NGINX Controller Agent installer script 'install.sh' uses HTTP instead of HTTPS to check and install packages
Affected products
- NGINX Controller: from 2.0.0 through 2.9.0; from 3.0.0 before 3.3.0; 1.0.1 — fixed in 3.3.0
- NetApp Cloud Backup: all versions
How to fix
Upgrade to a fixed version: NGINX Controller 3.3.0. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20200430-0005/
- https://support.f5.com/csp/article/K00958787
- https://security.netapp.com/advisory/ntap-20200430-0005/
- https://support.f5.com/csp/article/K00958787
Get alerted when CVE-2020-5867 or the next vulnerability affects your stack