What’s Vulnerable › Vulnerabilities
CVE-2020-5895
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-07 · updated 2026-06-17
- Weakness: CWE-732
Description
On NGINX Controller versions 3.1.0-3.3.0, AVRD uses world-readable and world-writable permissions on its socket, which allows processes or users on the local system to write arbitrary data into the socket. A local system attacker can make AVRD segmentation fault (SIGSEGV) by writing malformed messages to the socket.
Affected products
- NGINX Controller: from 3.1.0 before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: NGINX Controller 3.4.0. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20200522-0001/
- https://support.f5.com/csp/article/K95120415
- https://security.netapp.com/advisory/ntap-20200522-0001/
- https://support.f5.com/csp/article/K95120415
Get alerted when CVE-2020-5895 or the next vulnerability affects your stack