What’s Vulnerable › Vulnerabilities
CVE-2020-5987
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-10-02 · updated 2026-06-17
- Weakness: CWE-459
Description
NVIDIA Virtual GPU Manager contains a vulnerability in the vGPU plugin in which guest-supplied parameters remain writable by the guest after the plugin has validated them, which may lead to the guest being able to pass invalid parameters to plugin handlers, which may lead to denial of service or escalation of privileges. This affects vGPU version 8.x (prior to 8.5), version 10.x (prior to 10.4) and version 11.0.
Affected products
- NVIDIA Virtual GPU Manager: from 8.0 before 8.5; from 10.0 before 10.4; 11.0 — fixed in 10.4, 8.5
How to fix
Upgrade to a fixed version: NVIDIA Virtual GPU Manager 10.4, 8.5. Check the vendor advisory for mitigations.
References
- https://nvidia.custhelp.com/app/answers/detail/a_id/5075
- https://nvidia.custhelp.com/app/answers/detail/a_id/5075
Get alerted when CVE-2020-5987 or the next vulnerability affects your stack