What’s Vulnerable › Vulnerabilities
CVE-2020-6165
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-15 · updated 2026-06-17
- Weakness: CWE-276
Description
SilverStripe 4.5.0 allows attackers to read certain records that should not have been placed into a result set. This affects silverstripe/recipe-cms. The automatic permission-checking mechanism in the silverstripe/graphql module does not provide complete protection against lists that are limited (e.g., through pagination), resulting in records that should have failed a permission check being added to the final result set. GraphQL endpoints are configured by default (e.g., for assets), but the admin/graphql endpoint is access protected by default. This limits the vulnerability to all authenticated users, including those with limited permissions (e.g., where viewing records exposed through admin/graphql requires administrator permissions). However, if custom GraphQL endpoints have been configured for a specific implementation (usually under /graphql), this vulnerability could also be exploited through unauthenticated requests. This vulnerability only applies to reading records; it does not allow unauthorised changing of records.
Affected products
- Silverstripe: from 3.2.0 before 3.2.4; from 3.2.5 before 3.3.0; from 4.5.0 before 4.5.3 — fixed in 3.2.4, 3.3.0, 4.5.3
How to fix
Upgrade to a fixed version: Silverstripe 3.2.4, 3.3.0, 4.5.3. Check the vendor advisory for mitigations.
References
- https://www.silverstripe.org/download/security-releases/CVE-2020-6165
- https://www.silverstripe.org/download/security-releases/CVE-2020-6165
Get alerted when CVE-2020-6165 or the next vulnerability affects your stack