What’s Vulnerable › Vulnerabilities
CVE-2020-6535
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Insufficient data validation in WebUI in Google Chrome prior to 84.0.4147.89 allowed a remote attacker who had compromised the renderer process to inject scripts or HTML into a privileged page via a crafted HTML page.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 31, 32
- Google Chrome: before 84.0.4147.89 — fixed in 84.0.4147.89
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: Google Chrome 84.0.4147.89. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00069.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00041.html
- https://chromereleases.googleblog.com/2020/07/stable-channel-update-for-desktop.html
- https://crbug.com/1073409
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTRPPTKZ2RKVH2XGQCWNFZ7FOGQ5LLCA/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MYIDWCHG24ZTFD4P42D4A4WWPPA74BCG/
- https://security.gentoo.org/glsa/202007-08
- https://security.gentoo.org/glsa/202101-30
- https://www.debian.org/security/2021/dsa-4824
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00069.html
Get alerted when CVE-2020-6535 or the next vulnerability affects your stack