What’s Vulnerable › Vulnerabilities
CVE-2020-6806
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-25 · updated 2026-06-17
- Weakness: CWE-125
Description
By carefully crafting promise resolutions, it was possible to cause an out-of-bounds read off the end of an array resized during script execution. This could have led to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 68.6, Firefox < 74, Firefox < ESR68.6, and Firefox ESR < 68.6.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10
- Mozilla Firefox: before 74.0 — fixed in 74.0
- Mozilla Firefox ESR: before 68.6.0 — fixed in 68.6.0
- Mozilla Thunderbird: before 68.6.0 — fixed in 68.6.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 74.0; Mozilla Firefox ESR 68.6.0; Mozilla Thunderbird 68.6.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/157524/Firefox-js-ReadableStreamCloseInternal-Out-Of-Bounds-Access.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1612308
- https://usn.ubuntu.com/4328-1/
- https://usn.ubuntu.com/4335-1/
- https://www.mozilla.org/security/advisories/mfsa2020-08/
- https://www.mozilla.org/security/advisories/mfsa2020-09/
- https://www.mozilla.org/security/advisories/mfsa2020-10/
- http://packetstormsecurity.com/files/157524/Firefox-js-ReadableStreamCloseInternal-Out-Of-Bounds-Access.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1612308
- https://usn.ubuntu.com/4328-1/
- https://usn.ubuntu.com/4335-1/
- https://www.mozilla.org/security/advisories/mfsa2020-08/
Get alerted when CVE-2020-6806 or the next vulnerability affects your stack