What’s Vulnerable › Vulnerabilities
CVE-2020-6822
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-24 · updated 2026-06-17
- Weakness: CWE-787
Description
On 32-bit builds, an out of bounds write could have occurred when processing an image larger than 4 GB in <code>GMPDecodeData</code>. It is possible that with enough effort this could have been exploited to run arbitrary code. This vulnerability affects Thunderbird < 68.7.0, Firefox ESR < 68.7, and Firefox < 75.
Affected products
- Mozilla Firefox: before 75.0 — fixed in 75.0
- Mozilla Firefox ESR: before 68.7.0 — fixed in 68.7.0
- Mozilla Thunderbird: before 68.7.0 — fixed in 68.7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 75.0; Mozilla Firefox ESR 68.7.0; Mozilla Thunderbird 68.7.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1544181
- https://usn.ubuntu.com/4335-1/
- https://www.mozilla.org/security/advisories/mfsa2020-12/
- https://www.mozilla.org/security/advisories/mfsa2020-13/
- https://www.mozilla.org/security/advisories/mfsa2020-14/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1544181
- https://usn.ubuntu.com/4335-1/
- https://www.mozilla.org/security/advisories/mfsa2020-12/
- https://www.mozilla.org/security/advisories/mfsa2020-13/
- https://www.mozilla.org/security/advisories/mfsa2020-14/
Get alerted when CVE-2020-6822 or the next vulnerability affects your stack