What’s Vulnerable › Vulnerabilities
CVE-2020-7009
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-31 · updated 2026-06-17
- Weakness: CWE-266
Description
Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.
Affected products
- Elasticsearch: from 6.7.0 before 6.8.8; from 7.0.0 before 7.6.2 — fixed in 6.8.8, 7.6.2
How to fix
Upgrade to a fixed version: Elasticsearch 6.8.8, 7.6.2. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-6-8-8-and-7-6-2-security-update/225920
- https://security.netapp.com/advisory/ntap-20200403-0004/
- https://www.elastic.co/community/security/
- https://discuss.elastic.co/t/elastic-stack-6-8-8-and-7-6-2-security-update/225920
- https://security.netapp.com/advisory/ntap-20200403-0004/
- https://www.elastic.co/community/security/
Get alerted when CVE-2020-7009 or the next vulnerability affects your stack