What’s Vulnerable › Vulnerabilities
CVE-2020-7052
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-24 · updated 2026-06-17
- Weakness: CWE-770
Description
CODESYS Control V3, Gateway V3, and HMI V3 before 3.5.15.30 allow uncontrolled memory allocation which can result in a remote denial of service condition.
Affected products
- CODESYS Control for BeagleBone: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control For Empc-A/Imx6: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control for IOT2000: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control For Linux: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control for PFC100: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control for PFC200: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control For Plcnext: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control for Raspberry Pi: before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control Rte: from 3.5.8.60 before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control Runtime System Toolkit: from 3.0 before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Control Win: from 3.5.9.80 before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Gateway Server V2: from 3.5.15.10 before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Hmi: from 3.5.10.0 before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Safety SIL2: from 3.0 before 3.5.15.30 — fixed in 3.5.15.30
- CODESYS Simulation Runtime: from 3.5.9.40 before 3.5.15.30 — fixed in 3.5.15.30
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone 3.5.15.30; CODESYS Control For Empc-A/Imx6 3.5.15.30; CODESYS Control for IOT2000 3.5.15.30; CODESYS Control For Linux 3.5.15.30; CODESYS Control for PFC100 3.5.15.30; CODESYS Control for PFC200 3.5.15.30; CODESYS Control For Plcnext 3.5.15.30; CODESYS Control for Raspberry Pi 3.5.15.30; CODESYS Control Rte 3.5.15.30; CODESYS Control Runtime System Toolkit 3.5.15.30; CODESYS Control Win 3.5.15.30; CODESYS Gateway Server V2 3.5.15.30. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=12977&token=33f948eed0c2fd69d238d9515779be337ef7592d&download=
- https://www.tenable.com/security/research/tra-2020-04
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=12977&token=33f948eed0c2fd69d238d9515779be337ef7592d&download=
- https://www.tenable.com/security/research/tra-2020-04
Get alerted when CVE-2020-7052 or the next vulnerability affects your stack